Fb-Button  - standard facebook ico - Oracle botches CVE-2018-2628 patch and hackers promptly start scanning for vulnerable WebLogic installsSecurity Affairs

According to a expert, appears to have botched the CVE-2018-28 fix, this means that attackers could bypass it to take over servers.

Earlier April, Oracle patched the critical CVE-2018-2628 vulnerability in Oracle WebLogic server, but an Alibaba security researcher @pyn3rd discovered that the proposed fix could be bypassed.

The CVE-2018-2628 flaw was addressed in Oracle’s Critical Patch Update (CPU) security advisory, a remote attacker can easily exploit the vulnerability to completely take over an Oracle WebLogic server.

“Vulnerability in the Oracle WebLogic Server component of Oracle Fusion Middleware (subcomponent: WLS Core Components). Supported versions that are affected are 10.3.6.0, 12.1.3.0, 12.2.1.2 and 12.2.1.3.” reads the description provided by Mitre. “Easily exploitable vulnerability allows unauthenticated attacker with network access via T3 to compromise Oracle WebLogic Server. Successful attacks of this vulnerability can result in takeover of Oracle WebLogic Server. CVSS 3.0 Base Score 9.8 (Confidentiality, Integrity and Availability impacts).”

@pyn3rd added that it is quite easy to bypass the patch:

The popular cyber security expert Kevin Beaumont explained that the mitigation implemented by Oracle seems to only blacklist commands.

Such kind of errors could have serious consequences on the end users, since April 17, (just after Oracle published the quarterly Critical Patch Update (CPU) advisory). experts are observing threat actors started the Internet, searching for Oracle WebLogic servers.

After Oracle published the Critical Patch Updates, the researchers Xinxi published the technical details of the CVE-2018-2628  vulnerability and later a user with moniker ‘Brianwrf’ shared proof-of-concept (PoC) code on GitHub.

The availability of the PoC code caused a spike in scans for port 7001 that runs the WebLogic T3 service.

In the following graph from SANS Institute shows the spike in Internet scans for port 7001:

CVE-2018-2628 scans  - CVE 2018 2628 scans - Oracle botches CVE-2018-2628 patch and hackers promptly start scanning for vulnerable WebLogic installsSecurity Affairs

Pierluigi Paganini

(Security Affairs – CVE-2018-2628 Oracle WebLogic, hacking)








Source link

LEAVE A REPLY

Please enter your comment!
Please enter your name here