Oracle WebLogic Server  - Oracle 2BWebLogic 2BServer - Hackers Exploit Critical Oracle WebLogic Server Vulnerability

Hackers abuse Oracle WebLogic Server CVE-2019-2725 to deliver Monero Miner. The vulnerability is easily exploitable, any unauthenticated attacker with HTTP access to the server can attack without authentication.

Trend Micro observed a new cryptocurrency-mining activity involving the vulnerability and to hide the malicious code they used certificate files.

Infection

Malware exploits CVE-2019-272 to execute a PowerShell command to download the malicious code obfuscated in the .cer file. The PowerShell scripts download the encoded certificate file from the attacker’s server.

To decode the certificate file CertUtil is used, CertUtil is a command-line program that is installed along with Certificate Services.

- oracle weblogic1 - Hackers Exploit Critical Oracle WebLogic Server Vulnerability
Infection Chain

The extracted file update.ps1 is executed using PowerShell command, and the downloaded certificate is deleted using command.

“When we downloaded the certificate file, we noticed that it looked like a normal Privacy-Enhanced Mail (PEM) format certificate. However, upon decoding the base64 content, we found that, instead of the commonly used X.509 TLS file format, it comes in the form of the PS command,” reads Trend Micro report.

Last month another campaign leveraged the vulnerability to download Sodinokibi ransomware and to encrypt the customer’s systems.

It is recommended to patch the CVE-2019-2725 vulnerability; you can find the alert published by Oracle and the Patch Availability here.

Indicators of Compromise

SHA-256
e4bc026aec8a76b887a8fc48726b9c48540fc2aa76eb8e61893da2ee6df6ab3a
4b9842b6be35665174c78c3e4063c645bd6e10eb333f68e4c7840fe823647bdf
c30f42e6f638f3e8218caf73c2190d2a521304431994fd6efeef523cfbaa5e81
3a567b7985b2da76db5e5a1d5554f7c13f375d88a27d6e6d108ad79e797adc9

URLs
hxxp://139[.]180[.]199[.]167:12/clean[.]bat
hxxp://139[.]180[.]199[.]167:1012/config[.]json
hxxp://139[.]180[.]199[.]167:1012/networkservice[.]exe
hxxp://139[.]180[.]199[.]167:1012/sysguard[.]exe
hxxp://139[.]180[.]199[.]167:1012/sysupdate[.]exe
hxxp://139[.]180[.]199[.]167:1012/update[.]ps1
hxxp://45.32.28.187:1012
hxxp://45.32.28.187:1012/cert.cer
hxxps://pixeldrain[.]com/api/file/bg2Fh-d_
hxxps://pixeldrain[.]com/api/file/cGsOoTyb
hxxps://pixeldrain[.]com/api/file/cGsOoTyb/wujnEh-n1
hxxps://pixeldrain[.]com/api/file/DF1zsieq1
hxxps://pixeldrain[.]com/api/file/TyodGuTm

You can follow us on LinkedinTwitterFacebook for daily updates also you can take the Best Cybersecurity courses online to keep your self-updated.





Source link

No tags for this post.

LEAVE A REPLY

Please enter your comment!
Please enter your name here