Comodo Antivirus  - Comodo 2BAntivirus - Comodo Antivirus Affected With Multiple Vulnerabilities

Researchers discovered five critical vulnerabilities in Comodo Antivirus / Advanced version. Out of five vulnerabilities four present in version 12.0.0.68 and one with 11.0.0.682.

The vulnerabilities discovered at Tenable by David Wells, these vulnerabilities could be exploited by the attacker on the target system by “escaping sandbox as well as a privilege escalation to SYSTEM.”

Five Vulnerabilities – Comodo Antivirus

These vulnerabilities have been reported to Comodo in mid-April, but the time of writing, the vulnerabilities have not yet fixed.

CVE-2019-3969 – An attacker can gain access to the target system by escaping the Comodo Antivirus sandbox and can elevate the privileges to “NT AUTHORTIYSYSTEM” system user level.

CVE-2019-3970 – Arbitrary File Write present in Comodo Antivirus allows an attacker to modify the virus definition database, “allows an attacker to create false positives or simply bypassing AV signatures through deleting/modifying database data.”

CVE-2019-3971 – Denial of service flaw resides with CmdVirth.exe, a low privileged user can trigger the vulnerability by sending a LPC_DATAGRAM which triggers access violation due to hardcoded NULLs used for a memcpy source address results in process termination.

CVE-2019-3972 – Out-of-bounds can be caused by modifying the SharedMemoryDictionary structure that results in a possible crash.

CVE-2019-3973 – The Out-of-Bounds Write can be exploited to crash the application components and kernel crash.

David Wells published the PoC code on Github and also a video PoC for the flaw.

” At the time of this disclosure, we are not aware of any patches released by Comodo that address these vulnerabilities. We recommend to keep updated on future Comodo Antivirus releases. “

SponsoredFree GDPR Comics Book – Importance of Following General Data Protection Regulation (GDPR) to protect your Company Data and user privacy

You can follow us on LinkedinTwitterFacebook for daily updates also you can take the Best Cybersecurity course online to keep yourself updated.

Also Read

File Copy Vulnerability With ProFTPD puts Over 1 Million Servers at Risk

Critical Vulnerability in VLC Media Player 3.0.7.1 Let Hackers to Execute Arbitrary Code





Source link

No tags for this post.

LEAVE A REPLY

Please enter your comment!
Please enter your name here