Q will soon apps running on Lollipop or earlier

It’s only been a month since has released the latest version of Android 9.0 Pie, but it looks like the search giant has already started gearing up for Android Q. However, this time with Android Q, it plans to aggressively push developers to update their apps.

Last year, Google had released a new policy that imposed restrictions on the apps uploaded and updated on the Store. According to the policy, the new apps are required to target API (Application Programme Interface) level (Android 8.0 Oreo) as of last month or later version and the same API level for updates to existing apps from November 2018 onwards.

Besides this, a new commit (spotted by XDA-Developers) on the Android Open Source Project (AOSP) shows Android Q will warn attempting to install apps on the new platform that target Android Lollipop or lower.

An image quoted by XDA-Developers reads a warning message that says, “This app was built for an version of Android and may not work properly. Try checking for updates, or contact the developer.”

Google will be setting the minimum allowed target version from API level 17 (Android 4.2 Jelly Bean) to level 23 (Android 6.0 Marshmallow), which the warning will pop up each time users run an app that’s targeting Android 5.0 Lollipop or older. Although users will not be prevented from using the app, the pop-up will appear each time the app is opened until it is either deleted or updated.

By doing this, Google would apparently be shaming those developers who prefer not to update their API level in accordance with the new Android version so as to avoid implementing their runtime permissions.

Also, by targeting apps running Lollipop and older, Google wants to convey that these apps are not using the and privacy features that were introduced in Marshmallow. Additionally, this will also help Google to find out whether an app is updated or not.

On the other hand, if the developers upgrade to the latest version API, it will, in turn, bring a host of new features for the app. For instance, the new Android 9.0 Pie brings features like the Adaptive battery, App slices, App actions, UI changes, and much more.

If you are an Android app developer, we recommend you to start updating the apps or make a new one that may run properly on Android 8.0 Oreo and above.

ALSO READ: Android 9.0 Pie is here: How to get it and what’s new



Source link
Based Blockchain Network

LEAVE A REPLY

Please enter your comment!
Please enter your name here